搜索
瓜瓜678自助返现智讯云投资金融头条吧

[提问] 求大神编写指标

时间:2015-4-26 08:57 1 492 | 复制链接 |

该用户从未签到

1

主题

42

帖子

180

积分

积分
180
各位前辈,可以帮忙把通达信的一个指标编写成MT4的吗,万分感谢,编码如下:

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;

VAR2:=SMA(VAR1,9,1)+100;

VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR4:=SMA(VAR3,3,1);

VAR5:=SMA(VAR4,3,1)+100;

VAR6:=VAR5-VAR2;

趋势: IF(VAR6>45,VAR6-45,0);

STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),5,0),colorff00ff;

STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),5,0),color00ff00;

强弱分界:50,POINTDOT,Colorffffcc;

0,Color00Ffff;

20,POINTDOT,COlORFFAA66,linethick1;

80,POINTDOT,COlORFFAA66,linethick1;

100,Colorffff33;

v1:=LLV(LOW,10);

v2:=HHV(H,25);

价位线:=EMA((C-v1)/(v2-v1)*4,4);

DRAWTEXT(CROSS(价位线,0.3),7,'●'),ColorFFFfff;

DRAWTEXT(CROSS(3.5,价位线),102,'●'),ColorFFFfff;

Var2q:=REF(LOW,1);

Var3q:=SMA(ABS(LOW-Var2q),3,1)/SMA(MAX(LOW-Var2q,0),3,1)*100;

Var4q:=EMA(IF(CLOSE*1.3,Var3q*10,Var3q/10),3);

Var5q:=LLV(LOW,30);

Var6q:=HHV(Var4q,30);

Var7q:=IF(MA(CLOSE,58),1,0);

Var8q:=EMA(IF(LOW<=Var5q,(Var4q+Var6q*2)/2,0),3)/618*Var7q;

Var9q:=IF(Var8q>100,100,Var8q);

吸筹:STICKLINE(Var9q>-120,0,Var9q,6,1),coloryellow;

AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;

AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

AA5:=SMA(AA4,13,8);

走势:=CEILING(SMA(AA5,13,8));

AA6:=SMA(AA3,21,8);

卖临界:STICKLINE(走势-AA6>85,103,100,15,1),Color0000ff,linethick2;

该用户从未签到

1

主题

42

帖子

180

积分

积分
180
lwcq 发表于 2015-4-26 17:44:59 | 显示全部楼层 | 举报
哪位前辈来指点指点啊
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则


在线客服
快速回复 1 返回列表 返回顶部