搜索
瓜瓜678自助返现智讯云投资金融头条吧

[提问] 求助,请高手把通达信公式改成MT4的

时间:2015-4-22 09:16 6 781 | 复制链接 |

签到天数: 28 天

[LV.4]偶尔看看III

10

主题

334

帖子

853

积分

积分
853
本帖最后由 zhaoxj 于 2015-5-5 08:44 编辑

N:=17;
GDFZ0:=C;
GDFZ1:=H;
GDFZ2:=L;
TYA:=((((((((((GDFZ2 + GDFZ1) + GDFZ0) + REF(GDFZ0,1)) + REF(GDFZ2,1)) + REF(GDFZ1,1)) + REF(GDFZ0,2)) + REF(GDFZ2,2)) + REF(GDFZ1,2)) / 9));
HDA:=(((((HHV(TYA,(17 * 2)) + REF(HHV(TYA,(17 * 2)),1)) + REF(HHV(TYA,(17 * 2)),2)) + REF(HHV(TYA,(17 * 2)),3)) + REF(HHV(TYA,(17 * 2)),4)) / 5);
LDA:=(((((LLV(TYA,(17 * 2)) + REF(LLV(TYA,(17 * 2)),1)) + REF(LLV(TYA,(17 * 2)),2)) + REF(LLV(TYA,(17 * 2)),3)) + REF(LLV(TYA,(17 * 2)),4)) / 5);
A1:=(REF(HDA,1) = (HHV(TYA,((2 * N) + 0))));
B1:=(FILTER(A1,N));
HD:=(FILTER(B1,N));
A2:=(REF(LDA,1) = (LLV(TYA,((2 * N) + 0))));
B2:=(FILTER(A2,N) );
LD:=(FILTER(B2,N));
A:=(REF(HDA,BARSLAST(HD)));
B:=(REF(LDA,BARSLAST(LD)));
T1:=((BARSLAST(HD) < BARSLAST(LD)) AND (NOT(HD)));
T2:=((BARSLAST(HD) > BARSLAST(LD)) AND (NOT(LD)));
BF:=IF(T1,A,A);
HH:=MA(BF,1);
BG:=IF(T2,B,B);
LL:=MA(BG,1);
HH1:=(BARSLAST((GDFZ0 > (REF(HH,1) * 1.003))));
LL1:=(BARSLAST((GDFZ0 < (REF(LL,1) * 0.997))));
IF((HH1 < LL1),LL,DRAWNULL),,COLOR00FFFF;
IF((HH1 > LL1),HH,DRAWNULL),LINETHICK2,COLORFFFFFF;
DRAWICON(CROSS(HH1,LL1),HH,2);
DRAWICON(CROSS(LL1,HH1),LL,1);
STICKLINE((HH1 < LL1),OPEN,CLOSE,3,0),COLORRED;
STICKLINE((HH1 < LL1),HIGH,LOW,0,0),COLORRED;
STICKLINE((HH1 > LL1),OPEN,CLOSE,3,0),COLORFF00FF;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORFF00FF;



谢谢!

QQ图片20150505084532.png

签到天数: 34 天

[LV.5]常住居民I

20

主题

137

帖子

440

积分

积分
440
snfdf 发表于 2015-4-25 18:57:20 | 显示全部楼层 | 举报
首先大家可能不太了解通达信公式,其次没有图也不知道效果如何,能发个图上来吗?

签到天数: 28 天

[LV.4]偶尔看看III

10

主题

334

帖子

853

积分

积分
853
zhaoxj 发表于 2015-4-22 23:05:45 | 显示全部楼层 | 举报
没人帮我

签到天数: 28 天

[LV.4]偶尔看看III

10

主题

334

帖子

853

积分

积分
853
zhaoxj 发表于 2015-4-23 09:36:57 | 显示全部楼层 | 举报
ding

签到天数: 28 天

[LV.4]偶尔看看III

10

主题

334

帖子

853

积分

积分
853
zhaoxj 发表于 2015-4-25 18:26:39 | 显示全部楼层 | 举报
asdasdasd

签到天数: 2 天

[LV.1]初来乍到

0

主题

31

帖子

103

积分

积分
103
our420 发表于 2015-4-26 01:41:46 | 显示全部楼层 | 举报
支持楼上的观点

签到天数: 28 天

[LV.4]偶尔看看III

10

主题

334

帖子

853

积分

积分
853
zhaoxj 发表于 2015-5-5 08:47:23 | 显示全部楼层 | 举报
增加图片,有谁能帮忙变出啦吗
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则


在线客服
快速回复 6 返回列表 返回顶部